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(karypis@cs.umn.edu).

Intel@ Math Kernel Library, http://www.intel.com/software/products/mkl

SuperLU_MT version 2.0 - Copyright © 2003, The Regents of the University of California,
through Lawrence Berkeley National Laboratory (subject to receipt of any required
approvals from U.S. Dept. of Energy). All rights reserved. SuperLU Disclaimer: THIS
SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE
LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
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SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
POSSIBILITY OF SUCH DAMAGE.

7-zip - 7-Zip Copyright: Copyright (C) 1999-2009 Igor Pavlov. Licenses for files are:
7z.dll: GNU LGPL + unRAR restriction, All other files: GNU LGPL. 7-zip License: This library
is free software; you can redistribute it and/or modify it under the terms of the GNU
Lesser General Public License as published by the Free Software Foundation; either
version 2.1 of the License, or (at your option) any later version. This library is distributed
in the hope that it will be useful,but WITHOUT ANY WARRANTY; without even the implied
warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
Lesser General Public License for more details. You should have received a copy of the
GNU Lesser General Public License along with this library; if not, write to the Free
Software Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
unRAR copyright: The decompression engine for RAR archives was developed using source
code of unRAR program.All copyrights to original unRAR code are owned by Alexander
Roshal. unRAR License: The unRAR sources cannot be used to re-create the RAR
compression algorithm, which is proprietary. Distribution of modified unRAR sources in
separate form or as a part of other software is permitted, provided that it is clearly stated
in the documentation and source comments that the code may not be used to develop a
RAR (WinRAR) compatible archiver. 7-zip Availability: http://www.7-zip.org/

AMD Version 2.2 - AMD Notice: The AMD code was modified. Used by permission. AMD
copyright: AMD Version 2.2, Copyright © 2007 by Timothy A. Davis, Patrick R. Amestoy,
and Iain S. Duff. All Rights Reserved. AMD License: Your use or distribution of AMD or any
modified version of AMD implies that you agree to this License. This library is free
software; you can redistribute it and/or modify it under the terms of the GNU Lesser
General Public License as published by the Free Software Foundation; either version 2.1 of
the License, or (at your option) any later version. This library is distributed in the hope
that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser
General Public License for more details. You should have received a copy of the GNU
Lesser General Public License along with this library; if not, write to the Free Software
Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA Permission is
hereby granted to use or copy this program under the terms of the GNU LGPL, provided
that the Copyright, this License, and the Availability of the original version is retained on
all copies.User documentation of any code that uses this code or any modified version of
this code must cite the Copyright, this License, the Availability note, and "Used by
permission." Permission to modify the code and to distribute modified code is granted,
provided the Copyright, this License, and the Availability note are retained, and a notice
that the code was modified is included. AMD Availability:
http://www.cise.ufl.edu/research/sparse/amd

UMFPACK 5.0.2 - UMFPACK Notice: The UMFPACK code was modified. Used by permission.
UMFPACK Copyright: UMFPACK Copyright © 1995-2006 by Timothy A. Davis. All Rights
Reserved. UMFPACK License: Your use or distribution of UMFPACK or any modified version
of UMFPACK implies that you agree to this License. This library is free software; you can
redistribute it and/or modify it under the terms of the GNU Lesser General Public License

http://www.7-zip.org/
http://www.7-zip.org/
http://www.cise.ufl.edu/research/sparse/amd
http://www.cise.ufl.edu/research/sparse/amd
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as published by the Free Software Foundation; either version 2.1 of the License, or (at
your option) any later version. This library is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser General Public License for
more details. You should have received a copy of the GNU Lesser General Public License
along with this library; if not, write to the Free Software Foundation, Inc., 51 Franklin St,
Fifth Floor, Boston, MA 02110-1301 USA Permission is hereby granted to use or copy this
program under the terms of the GNU LGPL, provided that the Copyright, this License, and
the Availability of the original version is retained on all copies. User documentation of any
code that uses this code or any modified version of this code must cite the Copyright, this
License, the Availability note, and "Used by permission." Permission to modify the code
and to distribute modified code is granted, provided the Copyright, this License, and the
Availability note are retained, and a notice that the code was modified is included.
UMFPACK Availability: http://www.cise.ufl.edu/research/sparse/umfpack  UMFPACK
(including versions 2.2.1 and earlier, in FORTRAN) is available at
http://www.cise.ufl.edu/research/sparse . MA38 is available in the Harwell Subroutine
Library. This version of UMFPACK includes a modified form of COLAMD Version 2.0,
originally released on Jan. 31, 2000, also available at
http://www.cise.ufl.edu/research/sparse . COLAMD V2.0 is also incorporated as a built-in
function in MATLAB version 6.1, by The MathWorks, Inc. http://www.mathworks.com .
COLAMD V1.0 appears as a column-preordering in SuperLU (SuperLU is available at
http://www.netlib.org ). UMFPACK v4.0 is a built-in routine in MATLAB 6.5. UMFPACK v4.3
is a built-in routine in MATLAB 7.1.

Qt Version 4.6.3 - Qt Notice: The Qt code was modified. Used by permission. Qt copyright:
Qt Version 4.6.3, Copyright (c) 2010 by Nokia Corporation. All Rights Reserved. Qt
License: Your use or distribution of Qt or any modified version of Qt implies that you agree
to this License. This library is free software; you can redistribute it and/or modify it under
the
terms of the GNU Lesser General Public License as published by the Free Software
Foundation; either version 2.1 of the License, or (at your option) any later version. This
library is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Lesser General Public License for
more details. You should have received a copy of the GNU Lesser General Public License
along with this library; if not, write to the Free Software Foundation, Inc., 51 Franklin St,
Fifth Floor, Boston, MA 02110-1301 USA Permission is hereby granted to use or copy this
program under the terms of the GNU LGPL, provided that the Copyright, this License, and
the Availability of the original version is retained on all copies.User
documentation of any code that uses this code or any modified version of this code must
cite the Copyright, this License, the Availability note, and "Used by permission."
Permission to modify the code and to distribute modified code is granted, provided the
Copyright, this License, and the Availability note are retained, and a notice that the code
was modified is included. Qt Availability: http://www.qtsoftware.com/downloads  Patches
Applied to Qt can be found in the installation at:
$HPEESOF_DIR/prod/licenses/thirdparty/qt/patches. You may also contact Brian
Buchanan at Agilent Inc. at brian_buchanan@agilent.com for more information.

The HiSIM_HV source code, and all copyrights, trade secrets or other intellectual property
rights in and to the source code, is owned by Hiroshima University and/or STARC.

http://www.cise.ufl.edu/research/sparse/umfpack
http://www.cise.ufl.edu/research/sparse/umfpack
http://www.cise.ufl.edu/research/sparse
http://www.cise.ufl.edu/research/sparse
http://www.cise.ufl.edu/research/sparse
http://www.cise.ufl.edu/research/sparse
http://www.mathworks.com
http://www.mathworks.com
http://www.netlib.org
http://www.netlib.org
http://www.qtsoftware.com/downloads
http://www.qtsoftware.com/downloads
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Errata The ADS product may contain references to "HP" or "HPEESOF" such as in file
names and directory names. The business entity formerly known as "HP EEsof" is now part
of Agilent Technologies and is known as "Agilent EEsof". To avoid broken functionality and
to maintain backward compatibility for our customers, we did not change all the names
and labels that contain "HP" or "HPEESOF" references.

Warranty The material contained in this document is provided "as is", and is subject to
being changed, without notice, in future editions. Further, to the maximum extent
permitted by applicable law, Agilent disclaims all warranties, either express or implied,
with regard to this documentation and any information contained herein, including but not
limited to the implied warranties of merchantability and fitness for a particular purpose.
Agilent shall not be liable for errors or for incidental or consequential damages in
connection with the furnishing, use, or performance of this document or of any
information contained herein. Should Agilent and the user have a separate written
agreement with warranty terms covering the material in this document that conflict with
these terms, the warranty terms in the separate agreement shall control.

Technology Licenses The hardware and/or software described in this document are
furnished under a license and may be used or copied only in accordance with the terms of
such license. Portions of this product include the SystemC software licensed under Open
Source terms, which are available for download at http://systemc.org/ . This software is
redistributed by Agilent. The Contributors of the SystemC software provide this software
"as is" and offer no warranty of any kind, express or implied, including without limitation
warranties or conditions or title and non-infringement, and implied warranties or
conditions merchantability and fitness for a particular purpose. Contributors shall not be
liable for any damages of any kind including without limitation direct, indirect, special,
incidental and consequential damages, such as lost profits. Any provisions that differ from
this disclaimer are offered by Agilent only.

Restricted Rights Legend U.S. Government Restricted Rights. Software and technical
data rights granted to the federal government include only those rights customarily
provided to end user customers. Agilent provides this customary commercial license in
Software and technical data pursuant to FAR 12.211 (Technical Data) and 12.212
(Computer Software) and, for the Department of Defense, DFARS 252.227-7015
(Technical Data - Commercial Items) and DFARS 227.7202-3 (Rights in Commercial
Computer Software or Computer Software Documentation).

http://systemc.org/
http://systemc.org/
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 Command Reference for Instrument
Server
  

 File Menu
  

 Close Window

Closes the Instrument Server window.

  

 HP-IB Menu
  

 Symbolic Name

Specifies the symbolic interface name assigned to the interface bus card.

  

 Timeout

Specifies the maximum length of time allowed to transfer data. Instruments disconnect
after this time has elapsed.

  

 Help Menu
  

 What's This?

Displays context-sensitive help for a menu, command, button, or control that is selected
subsequently.

  

 Topics and Index

Provides access to a brief list of topics for each product area, as well as access to an index
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of topics in all product areas.

  

 Agilent EEsof Web Site

Launches the browser (Netscape by default) defined in Options > Preferences > Web
Browser in the Advanced Design System Main window, provided the path for the browser
has been established.

  

 About the Instrument Server

Displays version, copyright, and technical support information. Provides a direct link to the
Agilent EEsof web site.

  

 Read Instrument (Button)
Sends the measured instrument data to the dataset.

 

 Write To Instrument (Button)
Sends the selected dataset to the instrument.
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 Using Instrument Interfaces
There are two approaches to using instruments in ADS:

Using the Connection Manager1.
The Connection Manager (CM) is the recommended method for instrument
connectivity from ADS. The Connection Manager employs a client-server
environment, where the clients are supported on all ADS platforms, and the server is
on a PC. There are two types of Connection Manager based clients in ADS

The CM client UI that provides simple S-parameter, spectrum, and voltage
waveform measurements.
The CM simulation components that download data to/from instruments during
simulation.
For more information, refer to Connection Manager (connectmui).

Using legacy instrument interfaces2.
Though the CM is recommended for ADS instrument connectivity, ADS continues to
support legacy instrument interfaces like the Instrument Server and older instrument
components on Windows platforms only.

Note
Instrument connectivity using the Instrument Server and legacy instrument components is
supported on the Windows® 2000, Windows NT® 4.0 and Windows XP platforms only. On Unix®

platforms, instrument connectivity is supported primarily through the Connection Manager
architecture.

The Instrument Server and older instrument components rely on the older SICL IO library
for instrument connectivity. For this reason, instrument connectivity through the
Instrument Server and older instrument components are supported on PC platforms only.

For more information on the Instrument Server, refer to Using the Instrument Server
(instio).

For more information on instrument components, both CM and legacy, refer to About
Instruments Components (instruments).

 GPIB Interfaces 
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Description Part Number

Agilent LAN/GPIB Gateway Interface/ SICL drivers E2050A/B w/ Opt
AG6

Agilent LAN/GPIB Gateway Interface/ SICL drivers E5810A

Agilent USB/GPIB SICL/VISA drivers 82357A

Agilent GPIB PCI card / SICL drivers 82350A

Agilent GPIB EISA card / SICL drivers 82341C

National Instruments AT-GPIB/TNT card/NI-488.2M drivers 776836-01

National Instruments PCMCIA-GPIB card/NI-488.2M drivers 777332-02

National Instruments PCI-GPIB card/NI-488.2M/SICL drivers for Windows NT (Agilent IO
Libraries can substitute for the NI-488.2M drivers.)

777073-01

National Instruments PCI-GPIB card/NI-488.2M/SICL drivers for 778032-01

 

 Configuring the Driver for the GPIB Interface

To use GPIB interfaces with the Instrument Server or legacy instrument components in
ADS, download and install the most recent version of the Agilent IO libraries from the
website:

http://www.agilent.com/find/iolib

After installation is complete, run the IO Config program by selecting Start > Programs
> Agilent IO Libraries > IO Config from the Windows main screen. The following
graphic illustrates the IO Config application.

http://www.agilent.com/find/iolib
http://www.agilent.com/find/iolib
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To use a GPIB card installed locally on the PC, from the Available Interface Types field,
select the relevant GPIB option (based on the Interface Description provided on the right
hand side) and click Configure > OK . The default settings are correct.

To use a remote LAN/GPIB gateway, from the Available Interface Types field, select VISA
Lan Client > Configure . Enter the hostname or IP address and the sicl-name of the
LAN/GPIB gateway, and click OK .

Note
If the Instrument Server reports it's unable to find an interface, check to see if the system path contains
either gpib-32.dll, sicl32.dll or both.
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 Using the Instrument Server
The Instrument Server provides a way to write and read data to and from an instrument.

Applications for using transferred data include:

Reading measured instrument data into a dataset, and comparing measured data to
simulation results in a data display.
Reading data into a dataset for use with components, such as the VtDataset source,
that can read data from a dataset.
Writing S-parameters from a dataset to a specific file type. The S-parameter file can
then be read by a component, such as a P2D amplifier.

These are just a few examples, there are many other applications for transferring data
between Advanced Design System and outside systems.

This section describes how to transfer measured data between datasets and files, network
analyzers, spectrum analyzers, oscilloscopes, and the Agilent 70820A Microwave
Transition Analyzer.

The Instrument Server can transfer data between many instrument models and file
formats. A list of supported instruments appears at the start of each section.

Note
Currently, instrument connectivity for the Instrument Server is only supported on the following platforms:
Windows 2000 and Windows XP.

 

 Installation Requirements

Note
For details on the hardware and software installation, refer to [For more information on instrument
components, both CM and legacy, refer to Using Instrument Interfaces (instio).

To use the Instrument Server, you must first perform the following installation steps:

Install a GPIB card and software in your computer.
Run any installation procedures to set symbolic names, bus speed, et cetera.
Set GPIB and Instrument Server configurations in Advanced Design System.

Note
As part of the interface card installation, a symbolic name is assigned to the card. When you install the
card, make a note of this name, you will need it when you use the Instrument Server. For details on
specifying a symbolic name, refer to Specifying a Symbolic Interface Name.  

    

 Starting and Exiting the Instrument Server   
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To start the Instrument Server, from a Schematic window, choose Tools > Instrument
Server .

To exit the Instrument Server, choose File > Close Window from the Instrument Server
menu bar.

 

 The Instrument Server Dialog
The following illustration shows the default appearance of the Instrument Server user
interface.

The layout of the interface and names of the various elements vary with the task being
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performed (read or write) and whether a network analyzer, spectrum analyzer,
oscilloscope, or microwave transition analyzer is selected.

The following are the more frequently used elements of the interface:

The Menu bar displays the menus available from the dialog.
READ and WRITE display lists of items that you can read from and write to.
Depending on your selection, additional instrument options are displayed. 
Update Dataset List updates the list of available datasets.
Display Status Log activates the transfer of information to the Status Server. Any
errors that occur during the data transfer or messages that indicate the progress of
the transfer will appear in this window. 
Display Comments Dialog enables you to add comments to a dataset.  
The Datasets field list the datasets in the current workspace. The selected dataset or
the name of a new dataset is displayed in the Dataset Name field.  
The Blocks field lists the blocks (variables) in the selected dataset. The selected block
is displayed in the field below the list. 
The Read Instrument and Write To Instrument buttons execute the configured
measurement.

   

 Connecting to Instruments 
Several interface bus choices must be specified when you transfer data to or from an
instrument (Windows based systems only).

Data is transferred via the GPIB interface. (References to HP-IB in this text also refer to
GPIB).

To configure the interface bus, do the following:

Choose HP-IB > Timeout . The HPIB Timeout dialog box appears.1.
Enter the amount of time, in seconds, allowed to transfer data and click OK .2.
When this time is exceeded, the communication between the instrument and
computer is terminated. Do not specify an excessively long time because if the data
transfer fails, it may be difficult to terminate the connection between the computer
and the instrument until the time has expired. If you do not specify a time interval, a
default value of 10 seconds is used.     
Choose HP-IB > Symbolic Name . The HPIB Symbolic Name dialog box appears.3.
Enter the symbolic name of the interface card and click OK .4.
This name is required to transfer data via GPIB. For details on specifying a symbolic
name, refer to Specifying a Symbolic Interface Name.   
The HP-IB Address  field enables you to the identify the instrument that you want to5.
connect to by GPIB address.   

The steps to complete these settings begin with Specifying a Symbolic Interface Name.

 Data Transfer Considerations   
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To ensure successful data transfers, before initiating a transfer, be sure to:

Specify a timeout duration which is sufficient to complete the data transfer from an
instrument.
Set the instrument to hold or single sweep mode. This is particularly important when
retrieving averaged data from an instrument, or the data acquisition time for an
instrument is relatively long.
Do not change any settings on an instrument while a transfer is in progress.
Not all instruments have the same memory or trace locations, so be sure to select a
location that is valid for your instrument or an error will occur when you attempt to
transfer data.
You may need to use the Data File Tool to place data in a final format. For example,
you may have S-parameters in a Touchstone file and want them in P2D format. Using
the Data File Tool, you would read the S-parameters from the Touchstone file to a
dataset, then write the data from the dataset and into a P2D file. For more
information see, Working with Data Files (cktsim) in Using Circuit Simulators (cktsim)
.

  

 Reading and Writing Network Analyzer Data   
Data can be transferred to and from the following network analyzers.
    

 Network Analyzer Data

Model Number Description

Agilent 8510B/C/XF High Performance uW VNA

Agilent 8712X 300kHz - 1.3 GHz Low Cost (Trans, Refl) RF VNA

Agilent 8714X 300kHz - 3 GHz Low Cost (Trans, Refl) RF VNA

Agilent 8719X 50 MHz - 13.5 GHz VNA

Agilent 8720X 50 MHz - 20 GHz VNA

Agilent 8722X 50 MHz - 40 GHz VNA

Agilent 8752X 300kHz - 6 GHz Reflection Transmission VNA

Agilent 8753X 30kHz-6 GHz High Performance RF VNA

Agilent 8702X 300 kHz - 6 GHz Mod Freq Lightwave Component Analyzer

Agilent 8703X 130 MHz - 20 Ghz Mod Freq Lightwave Component Analyzer

Wiltron 360 High Performance uW VNA

Agilent E880X 300 kHz - 9 GHz Performance Network Analyzer †

Agilent E835X 300 kHz - 9 GHz Performance Network Analyzer †

Agilent N338X 300 kHz - 9 GHz Performance Network Analyzer †,††

Agilent E836X 45 MHz - 50 GHz Performance Network Analyzer †

  
^†Instrument Server does not support writing data to the analyzer waveform memory.
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††Instrument Server will only support reading S-parameters from ports 1 and 2.

  

 Network Analyzer Data Formats  

The network analyzer stores measurements as raw, corrected, or formatted data,
depending on the settings of the network analyzer:

Raw data are the values measured at the detector, with no correction or alteration.
Corrected data are the values measured at the detector, plus correction data applied.
Formatted data is corrected data plus any smoothing, or other processes that can be
applied with network analyzer.

Most Agilent Analyzers have two channels, each having its own set of raw, corrected and
formatted data arrays. For all analyzers except the 8712 and 8714 the Instrument Server
accesses the data in channel 1 only.
   

 Using the Agilent PNA Family Network Analyzers  

 

 Agilent PNA Family of Network Analyzers includes the E880X, E835X, E836X and N338X

Note
For the PNA family of network analyzers, including the E835X, E880X, E836X, N388X families, the
Instrument Server does not support writing to the analyzer waveform memory.

The Instrument Server has the ability to interface with the Agilent PNA Family of network
analyzers. The Instrument Server reads from the Channel 1 data arrays. There  
are two NWA data formats to choose from.

Corrected Transfer the data in the analyzer's Corrected data array to the dataset.
Raw Transfer the data in the analyzer's Raw data array to the dataset. Raw data for
all four S parameters is available regardless of whether a full 2-port-calibration is in
effect.

Corrected and Raw data is always stored in the dataset variable as complex real imaginary
pairs of the requested S parameters.

The Instrument Server will expect the data in the dataset to be complex.

 

 Using Agilent 87XX-Series Network Analyzers

The Instrument Server reads from and writes to the Channel 1 data arrays. The data of
interest in channel 1 does not have to be currently displayed to be read. If averaging is
ON, the Instrument Server will put the instrument in HOLD mode before reading the data.
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Therefore make sure that the instrument has sufficiently averaged the data before reading
the array.
 

In Read Mode there are three NWA data formats to choose from.

Formatted Transfer the data in the analyzer's Formatted data array to the dataset.
Corrected Transfer the data in the analyzer's Corrected data array to the dataset.
Raw Transfer the data in the analyzer's Raw data array to the dataset. Raw data for
all four S parameters is available regardless of whether a full 2-port-calibration is in
effect.

Data is always stored in the dataset variable as complex real imaginary pairs of the
requested S parameters.
 
 

In Write Mode there are two NWA Data Locations to choose from.

Memory Transfer complex data from the selected dataset variable to the Channel 1
Memory array.
Raw Transfer complex data from the selected dataset variable to the Channel 1 Raw
data array. If a full 2-port-calibration is in effect, any of the four S-parameters can
be written to the 4 available raw data arrays. If a full 2-port-calibration is not in
effect, S11 data must be selected in order to write to the single Raw data array
available.

The Instrument Server will expects the data in the dataset to be complex.

 

 Using Agilent 8752 Network Analyzers

Only S11 (reflection) and S21 (transmission) data can be read from or written to an Agilent

8752 network analyzer. This network analyzer only makes reflection and transmission
measurements, and reading or writing data for other parameters produces unpredictable
results.

Before data is written into a raw data array in the Agilent 8752 network analyzer, the
error correction that is built into the instrument must be turned off. This is not necessary
if data is written into memory in the instrument.

To turn off error correction in the Agilent 8752, follow these steps:

Press the menu key SYSTEM .1.
Press the function key SERVICE .2.
Press the function key SERVICE MODES .3.
Press the function key MORE .4.
Press the function key FREQ RESP to turn off the calibration.5.
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When this has been complete, you can write data into the raw data array in an Agilent
8752 network analyzer.

Note
Be sure to turn on error correction before making additional measurements with the network analyzer.

  

 Using Agilent 8510 Network Analyzers

The Instrument Server reads from and writes to the Channel 1 data arrays. The data of
interest in channel 1 does not have to be currently displayed to be read. If averaging is
ON, the Instrument Server will put the instrument in HOLD mode before reading the data.
Therefore make sure that the instrument has sufficiently averaged the data before reading
the array.

In Read mode there are three NWA data formats to choose from.

Formatted Transfer the data in the analyzer's Formatted data array to the dataset.
Corrected Transfer the data in the analyzer's Corrected data array to the dataset.
Raw Transfer the data in the analyzer's Raw data array to the dataset. Raw data for
all four S parameters is available regardless of whether a full 2-port-calibration is in
effect.

Data is always stored in the dataset variable as complex real imaginary pairs of the
requested S parameters.

In Write mode there are two NWA data locations to choose from.

Memory Transfer complex data from the selected dataset variable to the Channel 1
Corrected data array.
Raw Transfer complex data from the selected dataset variable to the Channel 1 Raw
data array. If a full 2-port-calibration is in effect, any of the four S-parameters may
be written to the 4 available raw data arrays. If a full 2-port-calibration is not in
effect, S11 data must be selected in order to write to the single Raw data array
available.

The Instrument Server will expects the data in the dataset to be complex.

    

 Reading Instrument Data from a Network Analyzer  

To read measured data from a network analyzer:

Configure the network analyzer by setting the stimulus, calibration, and other1.
parameters.
From an open Instrument Server window, click READ .2.
Under Read From, click Network Analyzer .3.
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Under NWA Data Format, select one of the following formats:4.
Formatted
Corrected
Raw

Under Read Network Analyzer Data, select the S-parameters that you want to use as5.
the data source. You can select one set of the S-parameters or create an S-matrix of
all S parameters.

Note
For PNA's that have more than two ports, the Instrument Server will only support reading S
parameters from ports 1 and 2. Specifically, the Instrument Server will read: S11, S12, S21, and
S22 (selecting "All S parameters" will read S11, S12, S21, and S22).

Type the network analyzer address in the HP-IB Address field.6.
Select HP-IB > Symbolic Name and enter a symbolic interface name. For more7.
information, refer to Specifying a Symbolic Interface Name.
If you want the data transfer to include a timeout, select HP-IB > Timeout . For8.
more information, refer to Specifying a Transfer Timeout.
Click Display Status Log to view any messages and errors that may occur during9.
the transfer.
Click Display Comments Dialog to add comments to a dataset. For instructions,10.
refer to Entering Comments into a Dataset.
Enter a name in the Dataset Name field, or select an existing dataset from the11.
Datasets list.
Enter a unique block name in the Enter Unique Block Name field. The instrument data12.
will be stored in this block name.

Note
You can select an existing block from the Blocks list, but you must edit the selected block name in
the Enter Unique Block Name field so that it is unique.

Click Read Instrument to send the measured instrument data to the dataset.13.

  

 Writing Data to a Network Analyzer   

Data in a dataset can be written to the network analyzer raw data array or memory array.
The memory array can only hold one parameter.

If data is to be written to the Channel 1 Raw data array, and a full 2-port-calibration is in
effect, any of the four S parameters may be written to the 4 available raw data arrays. If
a full 2-port-calibration is not in effect, S11 data must be selected in order to write to the
single Raw data array available.

To write to a network analyzer:

From an open Instrument Server window, click WRITE .1.
Under Write To, click Network Analyzer .2.
Under NWA Data Location, select the network analyzer data locations to identify3.
where you want to send the data.
Under Write Network Analyzer Data , select the type of S-parameters that you intend4.
to send to the analyzer.
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Type the network analyzer address in the HP-IB Address field.5.
Select HP-IB > Symbolic Name and enter a symbolic interface name. For more6.
information, refer to Specifying a Symbolic Interface Name.
If you want the data transfer to include a timeout, select HP-IB > Timeout . For7.
more information refer to Specifying a Transfer Timeout.
Click Display Status Log to view any messages and errors that may occur during8.
the transfer.
The source of the data can be any block in a workspace dataset. The data in the9.
dataset block must be complex data. Select from the list of existing datasets and
blocks.
Enter a unique block name in the Enter Name from Block List field.10.
Click Write To Instrument to send the data to the specified network analyzer11.
location.

      

 Reading and Writing Spectrum Analyzer Data    
Data can be read from and written to a wide range of spectrum analyzers. Supported
spectrum analyzers are listed below.

 Spectrum Analyzer Data

Model Number Features

Agilent 70000 Modular Analyzers (MMS)

Agilent 8566B 100 Hz-22 GHz

Agilent 8567A 10 kHz-1500 MHz

Agilent 8568B 100 Hz-1500 MHz

Agilent 859XX Portable Economy Analyzer Series

Agilent 856XX Portable Mil Spec Analyzer Series

  

  

 Reading Instrument Data from a Spectrum Analyzer 

   
When data is read into a dataset, the location specified as the source of the data (trace A,
B, or C) is read immediately without the selected trace being put into view mode.

When reading data from a spectrum analyzer, keep in mind the following:

The 856X series of analyzers do not have a Trace C.
The Instrument Server doesn't wait for the trace to complete before the data is read.
For traces with long sweep times, make sure the instrument has completed one
sweep of the desired spectrum before reading the data.
No peak search is performed before the data is transferred.
Data is read in exactly as it appears on the screen.
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The data written to the dataset variable has the amplitude units of the analyzer at
the time the data was read.

To read data from a spectrum analyzer:

From an open Instrument Server window, click READ .1.
Under Read From, click Spectrum Analyzer .2.
Under Read Spectrum Analyzer Trace, select the trace you want to use as the data3.
source.
Type the spectrum analyzer address in the HP-IB Address field.4.
Select HP-IB > Symbolic Name and enter a symbolic interface name. For more5.
information, refer to Specifying a Symbolic Interface Name.
If you want the data transfer to include a timeout, select HP-IB > Timeout . For6.
more information refer to Specifying a Transfer Timeout.
Click Display Status Log to view any messages and errors that may occur during7.
the transfer.
Click Display Comments Dialog to add comments to a dataset. For instructions,8.
refer to Entering Comments into a Dataset.
Enter a name in the Dataset Name field, or select an existing dataset from the9.
Datasets list.
Enter a unique block name in the Enter Unique Block Name field.10.

Note
You can select from the list of existing blocks in the Blocks list, but you must edit the selected block
name in the Enter Unique Block Name field so that it is unique. The instrument data will be stored in
this block.

Click Read Instrument to send the measured instrument data to the dataset.11.

  

 Writing to a Spectrum Analyzer

  
  
Existing data in the instrument memory to which data is being written is overwritten, and
the dataset data is displayed as if it were measured data. Since dataset data is deleted
from the instrument when another measurement is made, the Instrument Server places
the instrument in single sweep mode to prevent the dataset data from being overwritten.
Dataset data is deleted from the instrument when another measurement is made.

When data is written into the spectrum analyzer, the frequency range, number of points,
and other stimulus values in the instrument are not changed. Interpolation is used (if
necessary) to display the dataset data at the frequency points given by the current
spectrum analyzer settings. There must be some overlap between the frequency range of
the dataset and the analyzer's current frequency range. The spectrum analyzer does not
extrapolate. Data values for all frequencies above or below the frequencies in the dataset
appear as zero.

The Instrument Server searches the selected dataset variable for an attribute labeled
"Amplitude Units. If it is not found, the Instrument Server prompts the user for the unit
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value of the dataset variable data. The dataset variable data must be real data, complex
data will result in an error.

To write to a spectrum analyzer:

From an open Instrument Server window, click WRITE .1.
Under Write To, click Spectrum Analyzer .2.
Under Write to Spectrum Analyzer Trace, select the trace where you intend to send3.
the data.
Type the spectrum analyzer address in the HP-IB Address field.4.
Select HP-IB > Symbolic Name and enter a symbolic interface name. For more5.
information, refer to Specifying a Symbolic Interface Name.
If you want the data transfer to include a timeout, select HP-IB > Timeout . For6.
more information, refer to Specifying a Transfer Timeout.
Click Display Status Log to view any messages and errors that may occur during7.
the transfer.
Click Display Comments Dialog to add comments to a dataset. For instructions,8.
refer to Entering Comments into a Dataset.
The source of the data can be any block in a workspace dataset. Enter a name in the9.
Dataset Name field, or select a dataset from the Dataset list.
Enter a unique block name in the Enter Name from Block List field. The instrument10.
data will be stored in this block.

Note
You can select an existing block from the Blocks list, but you must edit the selected block name in
the Enter Name from Block List field so that it is unique.

Click Write To Instrument to send the dataset or block to the spectrum analyzer11.
trace.

      

 Reading and Writing Oscilloscope Data    
Data can be read from and written to a wide range of Agilent oscilloscopes. Supported
oscilloscopes are listed below.

 Oscilloscope Data
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Model Number Features

Agilent 54100A 1 GHz rep BW, 2-channel.

Agilent 54100D Agilent 54100A with dual trigger.

Agilent 54110D Agilent 54100D with color CRT and PaintJet output.

Agilent 54111D 500 MHz Rep BW, 250 MHz 1-shot, 2-channel dual trigger.

Agilent 54120T 20 GHz rep BW, 4-channel.

Agilent 54123T 34 GHz rep BW, 4-channel.

Agilent 54124T 50 GHz, 4-channel.

Agilent 54720D 2 GHz, 8 GSample/sec Modular Oscilloscope (using Agilent 5471X and 5472X plug-ins)

Agilent 54750A 20 GHz Sampling Modular Oscilloscope (using Agilent 5475X plug-ins)

Agilent 86100A 50 GHz DCA (digital communications analyzer)

Agilent 86100B 50 GHz high speed DCA (digital communications analyzer)

  

  

 Reading Instrument Data from an Oscilloscope

 
   
Not all channels or memory locations exist on all supported oscilloscopes. Requesting data
from a nonexistent channel results in an error message and no data is transferred.

Oscilloscope Memory Locations summarizes the memory locations from which data can be
read in various Agilent oscilloscopes.
 

 Oscilloscope Memory Locations

Oscilloscope Memory1
Memory2

Memory3
Memory4

Memory5Memory6 Memory5 through
Memory8

All † ‡ •    

Agilent 54120T • •   

Agilent 54123T • •   

Agilent 54110D • •   

Agilent 54111D • •  •

Agilent 547XX ‡ • • •  

† All instruments except Agilent 54100A/D oscilloscopes with firmware revisions earlier than March 1986. In
these earlier oscilloscopes, data is read from Channel 1 or 2 only.‡ Memory5 = fcn1, Memory6 = fcn2.

It may take a long time to read some extreme cases of averaged data. It is not
uncommon for it to take 10 to 15 minutes to accumulate 500 points of data averaged
2048 times. If such a trace is desired, store the trace in memory first, then read the data
directly from memory.

Also note that the Agilent 54111D oscilloscope stores 8192 points of data in waveform
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memories 1 through 4 even though only 512 of these points are displayed at any one
time. The result is that even if only two periods appear on the display, reading the
memory will take as long as is needed to read points for 16 periods.

  

 Using Agilent 541XXX-series Oscilloscopes

When reading data from an active channel, all Agilent 541XXX-series and Agilent 547XX-
series oscilloscopes first digitize the data into a waveform memory.

Oscilloscope Data Flow traces the flow of the data in each oscilloscope.
 

 Oscilloscope Data Flow

Agilent54100A/D † Agilent
54110D

Agilent
54111D

Agilent5412xx Agilent547xx

Where channel
1 is stored

Internal memory Memory 1 Memory 1 or
Memory 5 ‡

Memory 1 Internal memory

Where channel
2 is stored

Internal memory Memory 2 Memory 2 or
Memory 6 ‡

Memory 2 Internal memory

Where channel
3 is stored

   Memory 3 Internal memory

Where channel
4 is stored

   Memory 4 Internal memory

† Agilent 54100A/D oscilloscopes with firmware revisions later than March 1986 behave like Agilent 54110D
oscilloscopes.‡ The Agilent 54111D oscilloscope digitizes real-time traces from channels 1 and 2 into Memory
1 and Memory 2. It digitizes averaged traces from these two channels into Memory 5 and Memory 6.

To read data from an oscilloscope: 

From an open Instrument Server window, click READ .1.
Under Read From, click Oscilloscope .2.
Under Read Oscilloscope Data, select the channel or memory location that you want3.
to use as the data source.
Type the oscilloscope address in the HP-IB Address field.4.
Select HP-IB > Symbolic Name and enter a symbolic interface name. For more5.
information, refer to Specifying a Symbolic Interface Name.
If you want the data transfer to include a timeout, select HP-IB > Timeout . For6.
more information, refer to Specifying a Transfer Timeout.
Click Display Status Log to view any messages and errors that may occur during7.
the transfer.
Click Display Comments Dialog to add comments to a dataset. For instructions,8.
refer to Entering Comments into a Dataset.
Enter a name in the Dataset Name field, or select an existing dataset from the9.
Datasets list.
Enter a unique block name in the Enter Unique Block Name field. The instrument data10.
will be stored in this block.
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Note
You can select an existing block from the Blocks list, but you must edit the selected block name in
the Enter Unique Block Name field so that it is unique.

Click Read Instrument to send the measured instrument data to the dataset.11.

   

 Writing Advanced Design System Data to an Oscilloscope  

 
   
Not all memory locations are on all supported oscilloscopes. Writing data to a nonexistent
channel aborts the process with an error message and no data changes.
Oscilloscope Memory Locations summarizes the memory locations that are available for
writing data in various Agilent oscilloscopes.

Oscilloscope Memory1 Memory2 Memory3 Memory4 Memory5 through Memory8

ALL •

Agilent 54120T • •

Agilent 54123T • •

Agilent 54110D • •

Agilent 54111D • • •

Agilent 547XX • •

When data is written into the oscilloscope, the time range, number of points, and other
stimulus values in the waveform memory are not changed. Interpolation is used (if
necessary) to display the dataset data at the time points given by the current oscilloscope
settings. This means that the desired time/div, volts/div, delay, and other settings must
be adjusted on an active channel and then stored in memory.

The oscilloscope does not extrapolate. Data values for all times above or below the
frequencies in the dataset appear as zero.

To write to an oscilloscope:

From an open Instrument Server window, click WRITE .1.
Under Write To, click Oscilloscope .2.
Under Write To Oscilloscope Memory , select the memory location where you intend3.
to send the data.
Type the oscilloscope address in the HP-IB Address field.4.
Select HP-IB > Symbolic Name and enter a symbolic interface name. For more5.
information, refer to Specifying a Symbolic Interface Name.
If you want the data transfer to include a timeout, select HP-IB > Timeout . For6.
more information, refer to Specifying a Transfer Timeout.
Click Display Status Log to view any messages and errors that may occur during7.
the transfer.
Click Display Comments Dialog to add comments to a dataset. For instructions,8.
refer to Entering Comments into a Dataset.
The source of the data can be any block in a workspace dataset. Enter a name in the9.
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Dataset field, or select a dataset from the Datasets list.
Enter a unique block name in the Enter Name from Block List field. The instrument10.
data will be stored in this block.

Note
You can select an existing block from the Blocks list, but you must edit the selected block name in
the Enter Name from Block List field so that it is unique.

Click Write To Instrument to send the dataset or block to the specified oscilloscope11.
memory location.

      

 Reading and Writing Microwave Transition Analyzer
Data    
Data can be read from and written to the Agilent 70820A Microwave Transition Analyzer
(MTA).
   

 Reading Instrument Data from an MTA  

 
 
  
You can read MTA data from a trace, memory, or a table. Data can be in the following
format. The data read from a trace or memory location is formatted by the following Read
MTA data selections.

Formatted The format of the data depends on the instrument's current Domain
setting, which dictates how the trace data is to be displayed. Basically, this is a What
You See Is What you Get mode. The dependent data returned may be in Complex
(real, imaginary), Real, Imag, Magnitude, Phase, or Complex (magnitude, phase)
formats. The independent data can be either frequency or time.
Complex versus time The dependent data returned will be complex data, and the
independent data will be time. It doesn't matter what is currently being displayed on
the screen. The measured data will be transformed as necessary to output complex
data vs. time. For instance, if the instrument is currently displaying magnitude data
vs. frequency, an inverse FFT is performed so the independent data is time, and the
dependent data will be complex (real, imaginary).
Complex versus frequency The dependent data returned will be complex data, and
the independent data will be frequency. It doesn't matter what is currently being
displayed on the screen. The measured data will be transformed as necessary to
output complex data vs. frequency. For instance, if the instrument is currently
displaying real data vs. time, a FFT is performed so the independent data is
frequency, and the dependent data will be complex (real, imaginary).

If data is to be read from the MTA table, the Instrument Server checks to see if there is
more than 1 signal in the signal list. If there is more than 1 signal in the list, the
Instrument Server will prompt the user for the signal of interest. The magnitude data is
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changed to absolute amplitude values if it is originally relative. When the transfer is
started, the transition analyzer is put into hold mode if it is not in this mode already. Then
the data is read. This makes it possible to set up a trace, put the instrument in hold mode,
and then read the data. After the data has been read, the transition analyzer is returned
to its original sweep mode.

Details on transition analyzer domains appear under the description of the waveform
subsystem in the Agilent 70820A Transition Analyzer Remote Programming Manual .

To read data from an MTA: 

From an open Instrument Server window, click READ .1.
Under Read From, click Microwave Transition Analyzer .2.
Under Read MTA Trace, select one of the MTA Trace Formats: 3.

Trace 1-4: a displayed MTA trace
Memory 1-4: an MTA memory location
Table: If there is more than one signal in the signal list, the Instrument Server
will prompt the user for the signal of interest. The structure of the table is
retained. For example, a table may contain the magnitude and phase values of a
fundamental frequency and each of its harmonics. The data is transferred to the
dataset in the same order.

Under Read MTA Data, select one of the MTA Data Formats:4.
Formatted
Complex vs. Time
Complex vs. Frequency

Type the microwave transition analyzer address in the HP-IB Address field.5.
Select HP-IB > Symbolic Name and enter a symbolic interface name. For more6.
information, refer to Specifying a Symbolic Interface Name.
If you want the data transfer to include a timeout, select HP-IB > Timeout . For7.
more information, refer to Specifying a Transfer Timeout.
Click Display Status Log to view any messages and errors that may occur during8.
the transfer.
Click Display Comments Dialog to add comments to a dataset. For instructions,9.
refer to Entering Comments into a Dataset.
Enter a name in the Dataset Name field, or select an existing dataset from the10.
Datasets list.
Enter a unique block name in the Enter Unique Block Name field. The instrument data11.
will be stored in this block.

Note
You can select an existing block from the Blocks list, but you must edit the selected name in the
Enter Unique Block Name field so that it is unique.

Click Read Instrument to send the measured instrument data to the dataset.12.
   

 Writing Data to an MTA  

 
  
Any data that in the instrument memory location that you select to write to will be
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overwritten with the dataset data. The frequency range, number of points, and other
stimulus values in the instrument are reset to fit the trace being written.

To write to an MTA:

From an open Instrument Server window, click WRITE .1.
Under Write To, click Microwave Transition Analyzer .2.
Under Write to MTA Memory, select the memory location where you intend to send3.
the data.
Under Write MTA Data, select one of the MTA data types:4.

Frequency Domain Data as a function of frequency
Time Domain Complex data as a function of time

Type the microwave transition analyzer address in the HP-IB Address field.5.
Select HP-IB > Symbolic Name and enter a symbolic interface name. For more6.
information, refer to Specifying a Symbolic Interface Name.
If you want the data transfer to include a timeout, select HP-IB > Timeout . For7.
more information, refer to Specifying a Transfer Timeout.
Click Display Status Log to view any messages and errors that may occur during8.
the transfer.
Click Display Comments Dialog to add comments to a dataset. For instructions,9.
refer to Entering Comments into a Dataset.
The source of the data can be any block in a workspace dataset. Enter a name in the10.
Dataset Name field, or select a dataset from the Datasets list.
Enter a unique block name in the Enter Name from Block List field. The instrument11.
data will be stored in this block.

Note
You can select an existing block from the Blocks list, but you must edit the selected block name in
the Enter Name from Block List field so that it is unique.

Click Write To Instrument to send the dataset or block to the specified MTA12.
memory location.

   

 Specifying a Symbolic Interface Name  
 
The symbolic interface name is the name assigned to the interface card when the card is
installed. This name can be redefined at any time and is required by the Instrument
Server to transfer data to or from an instrument. For the E2050 Lan/GPIB gateway box,
the symbolic name is of the form:
lan[IP_address]:hp-ib_name

To enter the symbolic name:

From the menu bar choose HP-IB > Symbolic Name .1.
The HP-IB Symbolic Name dialog box appears. Type the name into the field in the2.
dialog box.
Click OK .3.
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Example:

If an E2050 Lan/GPIB gateway box with an IP address of 18.9.134.213 is to be addressed,
the symbolic name is:
lan[18.9.134.213]:hpib that is, lan[IP_address] : hp-ib_name
Refer to the documentation for the E2050 for details on changing the hp-ib_name.

Note
Interface cards for the PC are often bundled with a diagnostics program. If the diagnostics software is
installed, you can run it to identify the card name. UNIX platforms are not supported.

  

 Specifying a Transfer Timeout    
A transfer timeout specifies the length of time allowed to transfer data. When the time is
exceeded, the instrument and computer are disconnected. You should always set the
timeout option before a data transfer to ensure the connection between the instrument
and Advanced Design System can be terminated.

To set a timeout:

From the menu bar choose HP-IB > Timeout .1.
The HP-IB Timeout dialog box appears. Type the amount of time you want to allow to2.
elapse, in seconds, before the timeout occurs.
Click OK .3.

Note
The optimum transfer time depends on the hardware speed and the amount of data to be
transferred. If you transferring data from an instrument and are averaging data, transferring a large
amount of data, or have a long sweep time, put the instrument in hold or single sweep mode or
change the timeout setting to an appropriate value before attempting to transfer data.

  

 Entering Comments into a Dataset   
You can enter comments into a dataset. Comments such as the origin of the data can be
useful to identify the contents of the dataset.

To enter comments:

Click Display Comments Dialog .1.
Type in comments that you want to add to the dataset. The comments are entered2.
into a comments field of the dataset.
Click OK to add the comments to the dataset.3.
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